Linux AS 4.7 最小化安裝後安裝RPM包 MYSQL

Linux AS 4.7 最小化安装后安装RPM包安装 MYSQL 、
依赖关系解除!!
root@localhost RPMS]# rpm -ivh mysql*
warning: mysql-4.1.22-2.el4.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
perl(DBI) is needed by mysql-4.1.22-2.el4.i386
perl(DBI) is needed by mysql-bench-4.1.22-2.el4.i386
openssl-devel is needed by mysql-devel-4.1.22-2.el4.i386
perl(DBI) is needed by mysql-server-4.1.22-2.el4.i386
perl-DBD-MySQL is needed by mysql-server-4.1.22-2.el4.i386
perl-DBI is needed by mysql-server-4.1.22-2.el4.i386
Suggested resolutions:
/var/spool/up2dateopenssl-devel-0.9.7a-43.17.el4_6.1.i386.rpm
/var/spool/up2dateperl-DBD-MySQL-2.9004-3.1.i386.rpm
/var/spool/up2dateperl-DBI-1.40-9.i386.rpm
2、
[root@localhost RPMS]# rpm -ivh perl-DBI-1.40-9.i386.rpm
warning: perl-DBI-1.40-9.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing... ########################################### [100%]
1:perl-DBI ########################################### [100%]
3、
依次安装下列包
e2fsprogs-devel-1.35-12.17.el4.i386.rpm
krb5-devel-1.3.4-60.el4.i386.rpm
zlib-devel-1.2.1.2-1.2.i386.rpm
openssl-devel-0.9.7a-43.17.el4_6.1.i386.rpm
[root@localhost RPMS]# rpm -ivh perl-DBD-MySQL-2.9004-3.1.i386.rpm
warning: perl-DBD-MySQL-2.9004-3.1.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
libmysqlclient.so.14 is needed by perl-DBD-MySQL-2.9004-3.1.i386
Suggested resolutions:
/var/spool/up2datemysql-4.1.22-2.el4.i386.rpm
《注:在这一步中libmysqlclient.so.14 不是一个RPM包
查看其应属于是哪个RPM包的
rpm -q --redhatprovides libmysqlclient.so.14
mysql-4.1.22-2.el4
<得出libmysqlclient.so.14 是mysql-4.1.22-2.el4包的文件〉
继续依次安装 下列包
mysql-4.1.22-2.el4.i386.rpm
mysql-devel-4.1.22-2.el4.i386.rpm
mysql-server-4.1.22-2.el4.i386.rpm
mysql-bench-4.1.22-2.el4.i386.rpm
mysqlclient10-3.23.58-4.RHEL4.1.i386.rpm
mysqlclient10-devel-3.23.58-4.RHEL4.1.i386.rpm

所需包依次关系

perl-DBI-1.40-9.i386.rpm
e2fsprogs-devel-1.35-12.17.el4.i386.rpm
krb5-devel-1.3.4-60.el4.i386.rpm
zlib-devel-1.2.1.2-1.2.i386.rpm
openssl-devel-0.9.7a-43.17.el4_6.1.i386.rpm
rpm -ivh mysql-4.1.22-2.el4.i386.rpm
mysql-devel-4.1.22-2.el4.i386.rpm
mysql-server-4.1.22-2.el4.i386.rpm
mysql-bench-4.1.22-2.el4.i386.rpm
mysqlclient10-3.23.58-4.RHEL4.1.i386.rpm
mysqlclient10-devel-3.23.58-4.RHEL4.1.i386.rpm
附加:
rpm -q --redhatprovides libmysqlclient.so.14
来查看一下这个文件属于哪个RPM包说,
要用前面这个参数前要先安装rpmdb-redhat这个软件包
更多相关文章
  • 最小化安装RHEL-6后安装VMware-tools #./vmware-install.pl bash:./vmware-install.pl :/usr/bin/perl:bad interpreter:No such file or directory. 如果出现这个提示,则表明系统没有安装P ...
  • 1.项目背景 公司最近在生产环境上线内网dns服务器,开源组件选的是powerdns.其中客户端要安装powerdns-recursor,那么疑问来了,线上有100多台server,如何高效快速安装,就得我们运维考虑
  • 一. 简介 redhat采用了RPM软件包管理系统,RPM软件包管理系统具有强大的编译安装功能,但是由于历史原因,RPM软件包管理系统对软件之间的依存关系没有内部定义,造成安装RPM软件时经常出现令人无法理解的软件依
  • yum groupinstall "Desktop" yum groupinstall "X Window System" yum groupinstall "Desktop Platform" yum groupi
  • 0101 VMware Workstation安裝最小化linux
    VMware Workstation安装最小化CentOS-6.5   本文章适用各种想学linux的人员,也是自己的一个整理笔记(基于马哥linux的课程笔记总结).   需要准备的文件:     VMware Workstation:推荐使用VMware Workstation 11(界面变好看
  • 安装JsonCpp需要下载JsonCpp和Scon还需要机器上有python http://down.51cto.com/data/1882940 scons-2.3.2.tar下载 http://down.51cto.com/data/1882938 jsoncpp-src-0.5.0.tar下载
  • 安装最小化的LXDE桌面环境: pacman -S lxde-common 安装LXDE Session: pacman -S lxsession 不安装这个没法登录进桌面环境 安装LXDE面板: pacman -S
  • 最近拿来一台PC,12年的时候安装的CentOS6.2(x64),那个时候使用的是外置网卡,最小化安装系统时,主板自带网卡没有显示出来也就没注意,但是最近需要用到双网卡,就郁闷了.于是发生了下面一系列问题. 1.lspci命令没有 遇到问题: 在最小化安装的centos6.X系统中,使用lspci命
一周排行