Ubuntu10.04安装JAVA6

安装sun-java6

添加partner源deb http://archive.canonical.com/ lucid partner 到/etc/apt/sources.list文件中

(或者 sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner” 如果系统提示没有add-apt-repository命令,则需要先安装python-software-properties,命令sudo apt-get install python-software-properties。另外,有些版本的ubuntu即使安装了python-software-properties 也无add-apt-repository命令,此时需要手动添加此行"deb http://archive.canonical.com/ubuntu maverick partner"到/etc/apt/sources.list文件中。)

更新系统

sudo apt-get update

安装jre

sudo apt-get install sun-java6-jre sun-java6-plugin

以下列出此软件安装协议:



    		    Ubuntu10.04安装JAVA6

提示我们是否遵循此协议:




    		    Ubuntu10.04安装JAVA6

sun-dlj-v1-1 license has already been accepted
Setting up sun-java6-jre (6.24-1build0.10.04.1) ...Setting up sun-java6-bin (6.24-1build0.10.04.1) ...
update-alternatives: using /usr/lib/jvm/java-6-sun/jre/bin/ControlPanel to provide /usr/bin/ControlPanel (ControlPanel) in auto mode.
update-alternatives: using /usr/lib/jvm/java-6-sun/jre/bin/java_vm to provide /usr/bin/java_vm (java_vm) in auto mode.
update-alternatives: using /usr/lib/jvm/java-6-sun/jre/bin/javaws to provide /usr/bin/javaws (javaws) in auto mode.
update-alternatives: using /usr/lib/jvm/java-6-sun/jre/bin/jcontrol to provide /usr/bin/jcontrol (jcontrol) in auto mode.
update-alternatives: using /usr/lib/jvm/java-6-sun/jre/bin/policytool to provide /usr/bin/policytool (policytool) in auto mode.

>>>阅读全文

本文出自 “网人linux社区” 博客,转载请与作者联系!

更多相关文章
  • 原文地址:http://forum.ubuntu.org.cn/viewtopic.php?t=200605 After read <Ubuntu8.04下如何安装arm-linux编译及调试工具>, I setup all the tools step by step successf ...
  • 


    		    ubuntu10.04 安装fcitx4.0
    linux下一直没有很好用的输入法,原先的fcitx早在09吧,已经停止更新最新版本是3.6.3!用起来也不是很爽650) this.width=650;" onclick='window.open("http://blog.51cto.com/viewpic.php?refim ...
  • 直接进入主题吧,用ubuntu10.04光盘启动电脑,进入LIVECD模式. sudo -i 先来找一找你的ubuntu10.04安装在那个分区,用: fdisk -l 我的部分输出如下: Device Boot Start End Blocks Id System /dev/sda1 1 914 ...
  • 对于运维人员来说,如果没有特别的需求,用源安装无疑是大家最愿意的选择. 常见的vps都是ubuntu10.04,其源中没有php5-fpm,安装的时候会提示: Reading state information... Done E: Couldn't find package php5-fpm 解决 ...
  • 所需软件包 确认你安装好的系统上已经安装如下软件包再继续. Apache2 GCC编译器与开发库 GD库与开发库 可以用apt-get命令来安装这些软件包,键入命令: sudo apt-get install apache2 sudo apt-get install libapache2-mod-p ...
  • ubuntu10.04 svn安装方法:sudo apt-get install subversion sudo apt-get install libneon27-dev orsudo apt-get install libneon27 cd /usr/libsudo mv libneon-gnu ...
  • 半天后,尝试,引用网络上的零散资源,成品博客Leach协议ubuntu10.04在安装(12.04也可以在右侧安装,然而,实施效果的不,求解决~~),并制作了补丁. 一个关键的安装步骤如下面: 1.在用户文件夹创建一个新的文件夹,所谓随机.忠告"Leach". 2.将一键安装包中 ...
  • 10.04 先将 ubuntu server 的 iso 放到优盘上,然后在提示无法找到光驱时,按 alt+f2 打开一个新的 console 窗口,将 iso mount 上,具体操作如下: ls /dev/sd* mkdir /mnt/usb /mnt/iso mount -t vfat /de ...
一周排行
  • 5. 重定义错误.     一个最终的可执行文件里,绝对不允许出现两个同名的全局变量,也不允许出现同名的全局函数.     全局函数:只要不用 static 修饰符修饰的函数,全部都是全局的.     全局变量:函数
  • Vijos1028魔族密碼
    风之子刚走进他的考场,就……花花:当当当当~~偶是魅力女皇——花花!!^^(华丽出场,礼炮
  • <context:component-scan/>会注入如下classSet<BeanDefinitionHolder> beanDefinitions = ClassPathBeanDefi ...
  • 


    		    品鮮&mdash;Ext4.1發布,驚豔了我
    小注:客户端编辑还是用的不好..顺便请问其他博友,博客是否支持CSS,我在客户端编辑器里写 ...
  • The future will see bigger, more pervasive, transparent and advanced software catering to the growing comple ...
  • --查看过程.函数视图 dba_source user_source all_source --删除存储过程 drop procedure SP_TMP; drop function fun_tmp; ---函数 t
  • 1.phpPgAdmin不需要安装,直接从Sourceforge下载压缩包,解压到“/var/www/”文件夹下即可.       解压后,要为该文件夹赋予root用户和root组的权限       chown -R
  • 1. Take var expr = context.Products .Take(10); var expr = (from p in context.Products select p) .Take(10); S
  • 第一步:新建一个DataSnap Server 应用程序   第二步:选择伺服形态   第三步:
  • http://zhidao.baidu.com/link?url=lj_5iV8stQh1aSCAS97iGb09N4CY1PlBReaELJsnduZTnGSd8jUR3EUHNpQqk72AwJ3BxSF-4w6 ...