linux安裝rpm包時遇到Failed dependencies的解決辦法

最近在学LINUX,在centos5.11 安装rpm包时遇到Failed dependencies

[root@localhost CentOS]# rpm -ivh gcc-4.1.2-55.el5.x86_64.rpm
error: Failed dependencies:
glibc-devel >= 2.2.90-12 is needed by gcc-4.1.2-55.el5.x86_64

郁闷了好久

终于找到解决的辦法了,感谢网上的朋友们

加上两个参数 --nodeps --force

意义是安装时不再分析包之间的依赖关系而强制直接安装

[root@localhost CentOS]# rpm -ivh gcc-4.1.2-55.el5.x86_64.rpm --nodeps --force

Preparing... ########################################### [100%]
1:gcc ########################################### [100%]

不再提示Failed dependencies了

更多相关文章
一周排行